text.skipToContent text.skipToNavigation

Setting up a 1720 router and a Linksys BEFVP41

Please follow the instructions bellow to setup the 1720 router and the BEFVP41:

Pre–Install information

In this example we’re assuming that the 1720 router is setup with a public IP Address of 140.111.1.2 and a Local Secure Group of 192.168.2.0.  Also our example is assuming that the BEFVP41’s public IP address is 140.111.1.1 and it’s Local Secure Group is 192.168.1.0.  Please make any necessary changes for your environment.  This example is assuming that your BEFVP41 has already been setup, and is on the internet, and no tunnels have been setup.

Setting up the BEFVP41

1.      Open a web browser (Such as Internet Explorer or Netscape) and input "http://192.168.1.1" into the “Address” area.

2.      You’ll be prompted for a “User Name” and “Password”, leave the “User Name” blank and input the router’s password.  By default the routers password is admin.

3.      After arriving at the routers setup page, you’ll need to click on the VPN tab.

4.      When the “VPN” area appears, you’ll see the first tunnel.  Under the “This Tunnel” area, you’ll need to click on the radio button next to Enable, then input the “Tunnel Name”.

Note – The “Tunnel Name” is for reference only and does not impact the VPN Connection.

5.       For this example we will be opening the entire subnet on the LAN side.  Make sure that the “Local Secure Group” is set to Subnet.  After you do that you’ll need to fill in the IP, which would be 192.168.1.0 and the Subnet “Mask” would be 255.255.255.0.

6.      Next you'll need to assign the "Remote Secure Group", which is the network which you wish to access on the other side of the VPN tunnel.  In our example we’re going to set the “Remote Secure Group” to be a Subnet, with the “IP” of 192.168.2.0 and the Subnet “Mask” of 255.255.255.0.

7.      After you define the “Local Secure Group” and the “Remote Secure Group” you’ll need to specify the “Remote Security Gateway”, which would be the Public IP address of the 1720 router.  For our example we’ll set the “Remote Security Gateway” to IP Addr., and the value to 140.111.1.2.

8.      Next we’ll need to set the “Encryption” and “Authentication”.  For our example we will use DES and MD5.

9.      Now we need to setup the “Key Management”, which for our example, we’ll use Auto. (IKE).  After we set that up, we’ll need to define the “Pre-shared Key” and the “Key Lifetime”.  For our example we’re using a “Pre-shared Key” of XYZ123 and a “Key Lifetime” of 3600 seconds, or 1 Hour.

10. After you’ve finished setting the router, you’ll need to click Apply, then Continue.

After you finish configuring the router, the VPN page should look similar to this:

Setting up your 1720 router

The following is an example setup for your 1720 router:

Using 1925 out of 29688 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 1720 router

!

no logging buffered

no logging buffered

logging rate-limit console 10 except errors

enable password 7 105D0C0D1007

!

memory-size iomem 25

ip subnet-zero

no ip finger

no ip domain-lookup

ip dhcp excluded-address 192.168.2.1 192.168.2.99

!

ip dhcp pool 1

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

!

ip audit notify log

ip audit po max-events 100

!

!

crypto isakmp policy 1

 authentication pre-share

 group 2

!

crypto isakmp policy 2

 hash md5

 authentication pre-share

 group 2

!

crypto isakmp policy 3

 authentication pre-share

!

crypto isakmp policy 4

 hash md5

 authentication pre-share

crypto isakmp key XYZ123 address 140.111.1.1

!

!

crypto ipsec transform-set rtpset1 esp-des esp-md5-hmac

crypto ipsec transform-set rtpset2 esp-des esp-sha-hmac

crypto ipsec transform-set rtpset3 esp-null esp-md5-hmac

crypto ipsec transform-set rtpset4 esp-null esp-sha-hmac

crypto ipsec transform-set rtpset5 esp-des

!

crypto map rtp 1 ipsec-isakmp

 set peer 140.111.1.1

 set transform-set rtpset1 rtpset2 rtpset3 rtpset4 rtpset5

 match address 101

!

!

!

!

interface Ethernet0

 description connected to EthernetLAN_1

 ip address 140.111.1.2 255.255.255.0

 half-duplex

 crypto map rtp

!

interface FastEthernet0

 description connected to EthernetLAN

 ip address 192.168.2.1 255.255.255.0

 speed auto

!

router rip

 version 2

 network 140.111.0.0

 network 192.168.2.0

 no auto-summary

!

ip kerberos source-interface any

ip classless

ip route 0.0.0.0 0.0.0.0 140.111.1.1

no ip http server

!

access-list 101 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

snmp-server community public RO

!

line con 0

 exec-timeout 0 0

 password 7 070E25414707

 login

 transport input none

line aux 0

line vty 0 4

 password 7 1304131F0202

 login

!

end

Finishing up

After you setup your 1720 router to communicate with the BEFVP41, you should be able to establish a VPN tunnel between your BEFVP41 and your 1720 router.

Was this support article useful?

Additional Support Questions?

Search Again

CONTACT SUPPORT